dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
3514
share rss forum feed


PaleRider

@teksavvy.com

[DSL] Curse you Sagemcom 2864! (or why wont you let me telnet!)

Unfortunately these threads were no help:

»Firmware + Sagemcom Modem + Help

»Sagemcom firmware update

»Sagemcom F@st 2864 unlock on *nix

I can't seem to enable telnet on my new (from yesterday) Sagemcom 2864 from Bell for my brand spanking new Teksavvy 25/10 vdsl service, which otherwise is performing better then I was expecting for my neighbourhood.

/save_rg_conf.cgi returns a "500 Internal Server Error" with no meaningful details and going to /replace_rg_conf.cgi without actually sending a file sends me /conf_upload_failure.shtml and returns a "404 Not Found"

I've searched around without much luck on other sites and it seems I'm stuck for the moment.

Firmware version: FAST2864_v6740S
Rescue Version: FAST2864_v7740S
Hardware Version: 2864-000000-002

I'm trying to get my dsl stats into graphite to make the purty picaturs of my line condition over time. If anyone has any ideas fire away! If you have telnet and you have the same firmware I'd kill to get a copy of your /save_rg_conf.cgi output since the replace cgi seems to half work and I might be able to get into the sagemcom that way.

Cheers

henry128

join:2010-09-03
Mississauga, ON

Re: [DSL] Curse you Sagemcom 2864! (or why wont you let me telne

Hmm.... you're right. Although the new firmware didn't disable telnet access, it did disable retrieving the config file using save_rg_conf.cgi... Not good.

mikefallen

join:2010-01-27
Scarborough, ON
reply to PaleRider
yup same here tool doesnt work


creed3020
Premium
join:2006-04-26
Kitchener, ON
kudos:2
reply to PaleRider
Sounds like the new firmware didn't change telnet status by accident...or at least that would be what my bet is on.


joni_vdsl

@speakeasy.net
reply to PaleRider
I also experienced the same problem - however - after a few tries logged in as admin, and in incognito mode (i.e. not logged in), it eventually let me have the file, HomeGateway.conf -- keep trying,

lawrenson

join:2012-02-22

1 edit
That's interesting, maybe they unintentionally broke it.

My modem didn't get the firmware yet but I'd like to take a look at what they actually did. If anyone that got the update still has access to telnet and is willing to send me a file, please PM me.

edit: Got it, thanks


TilhasBB
Premium
join:2000-08-05
canada

1 edit
I can telnet into the modem but I can't use the telnet tool to get the file. If you can tell me how to get the file I'll send it over.

UPDATE: Check your Inbox!

I'm guessing if I reboot my modem I'm SOL!

lawrenson

join:2012-02-22
reply to PaleRider
It appears the functionality to save and replace the config has been removed completely.


TilhasBB
Premium
join:2000-08-05
canada
how come i have access to mine?

PaleRider

join:2012-12-10
canada
reply to TilhasBB
Since my first post was anon I didn't get any files. I've since made an account with the same name so if you can send me the file or a link that'd be great. Thanks for the help

henry128

join:2010-09-03
Mississauga, ON
Apparently you can retrieve a config file using "conf print /"... (I, for one, did not have the foresight to keep a copy of the config file before the firmware update)

The admin account for this config file is "admin" and "password".

I don't know if it's safe to use the config file on another modem. It has a bunch of MAC addresses that ought to be unique to my modem.

Roop

join:2003-11-15
Ottawa, ON
reply to PaleRider
cool stuff. i got a new sagemcom today, i turned off the local sign in on the internet page right away so i wouldn't get the update. the CLI is nice. anyone find any cool stuff in the shell?

HomeGateway> system shell
Temporary setting log_level off

BusyBox v1.01 (2005.09.07-07:38+0000) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

#