dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
5183
share rss forum feed


Riswan

@89.211.35.x

[Config] Cisco 877 router configuration for ADSL connection

Hi guys,

I am totally new to configuration of router. I have only basic knowledge on router configuration.

I am having a Cisco 877 Router with me and an ADSL connection which was not in use. Now my manger instructed me to check our ADSL with Cisco Router. I tried connecting to connection, but i couldnt do it. I googled and found some configuration. but still no hopes. So can any one help me on this. and also explain me the configuration

Its PPoE connection type
VPI:8
VCI:35
Multiplex-LLC
mtu-1460

hostname ADG
!
enable secret 5
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
no snmp trap link-status
pvc 8/35
pppoe-client dial-pool-number 1
!

interface dialer 1
ip address negotiated
encapsulation ppp
ppp authentication chap callin
ppp chap hostname 4673029
ppp chap password 0 234
ppp ipcp route default
dialer pool 10
no shut
exit
!

interface FastEthernet1
duplex auto
speed auto
!
interface FastEthernet2
duplex auto
speed auto
!
interface FastEthernet3
duplex auto
speed auto
!
interface FastEthernet4
duplex auto
speed auto
!

ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit any
access-list 23 permit 10.10.10.0 0.0.0.255
access-list 23 permit 172.16.1.0 0.0.0.255
dialer-list 1 protocol ip permit
!
!
!
!
control-plane
!
!
line con 0
password cisco
login
no modem enable
line aux 0
line vty 0 4
password cisco
login
!
scheduler max-task-time 5000
!
webvpn context Default_context
ssl authenticate verify all
!
no inservice
!
end



TomS_
Git-r-done
Premium,MVM
join:2002-07-19
London, UK
kudos:5

Need more info. What isnt working?

No sync?
Unable to login?
Syncs and logs in ok, but unable to connect to Internet?


HELLFIRE
Premium
join:2009-11-25
kudos:16
reply to Riswan

Seconded. Is it a physical, logical, or Layer 8 problem?

I'd start here with what to do to troubleshoot the first 2 issues, if that's the case.

Regards


cramer
Premium
join:2007-04-10
Raleigh, NC
kudos:8
reply to Riswan

First obvious problem... dialer pool 1 on the dsl interface but 10 on the ppp dialer.

Second, VLAN1 (the 4 port ethernet switch) isn't configured, so there's no connection through it. And third, NAT isn't configured -- not necessary if you have a block of static addresses.


markysharkey
Premium
join:2012-12-20
united kingd

4 edits
reply to Riswan

You need to add IP NAT inside to Int VLAN 1 which is missing so needs to be added, and IP NAT Outside to the dialer. It should go something like this:

Router(config)# int vlan 1
Router(config-if)#ip address x.x.x.x [mask] (use whichever RFC1918 address range you want.)
Router(config-if)#ip nat inside
Router(config)#int dialer 1
Router(config-if)#ip nat outside


NAT command is there but it points to Dialer 0 when the Dialer is Dialer 1.
Router(config)#ip nat inside source list 1 interface dialer 1 overload should fix the NAT command itself.
Remember to remove the current NAT line as well.
Router(config)#no ip nat inside source list 1 interface dialer 0 overload

Then you need a default route;
Router(config)#ip route 0.0.0.0 0.0.0.0 dialer 1

Access-List 23 can be removed as it isn't doing anything. 23 is the default number used by the SDM and is often copied across un-necessarilly. It's usually applied to the VTY lines to control Telnet / SSH access.
What about DHCP? The 877 can be used as a DHCP server if you want. If you're removing a "normal" consumer ADSL router chances are it was acting as the DHCP server as well.