dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
917
share rss forum feed


Shanester

join:2010-10-04
Banff, AB

[AB] How do I forward ports?

Greetings,

I have an Actiontec V1000H modem. I have tried to set up port forwarding myself, but the Actiontec automatically sets the remote ports to be the same as the local (LAN) ports. The Zend Debug server uses a random port every time it tries to connect to me.

The modem allows me to set the remote IP address to "any", but how can I set the remote ports to "any"?

Thanks,
Shane.



Tornado15550

join:2012-12-16
Canada

I found this website quite useful:
»portforward.com/english/routers/···ault.htm



Shanester

join:2010-10-04
Banff, AB

Thanks. I tried the default guide, as they don't have a guide for Zend Debugger. Unfortunately, it set my remote ports to be the same as my local (LAN) ports.

I've contacted Actiontec support, but they sent me an email saying that they don't offer support, and that I would have to contact Telus. Telus says that they also don't offer support (other than setting up wireless), and that I would have to contact Actiontec.

I'm really stuck.

Shane.


TiberiusX
Premium
join:2011-01-05
Edmonton, AB
reply to Shanester

Try using 0/1-65535. This is the range of available ports, and thus is the magical "any". Although I would recommend finding out if there is a way to restrict the port range the service uses, or if they already use a certain port range.

Tiberius


ruiner

join:2012-03-10
Canada

0 - 65535 probably won't work since the Actiontec will have at least 1 port bound to itself.

This is what DMZ is for, but you are better off restricting the port range the debugger is using. See here: »files.zend.com/help/PDT/installe···gers.htm



Shanester

join:2010-10-04
Banff, AB

I tried to specify "0" for the remote port, but the Actiontec just says that its invalid.

The instructions (below) says "Zend Debugger opens a random port on the server and connects to port 10137" on the client. The "random" port is actually between 1,024 and 65,535.

»forums.zend.com/viewtopic.php?f=···62#p3551

I didn't know that a router had a port bound to itself. Is it easy to find out what it is?

I tried putting my machine's IP address in the DMZ, but the Zend Debugger still couldn't connect back to me. My machine should have been exposed to the Internet, but Windows Firewall wasn't logging any dropped packets.

Telus has customised the firmware on this router. For example, you can't turn the Firewall off. You can still put a computer into the DMZ, but when I went to ShieldsUP! on grc.com, it still seemed like there was a firewall in place. Is there another way to test if the DMZ is working?

Shane.


ruiner

join:2012-03-10
Canada

0 is a reserved port so it probably won't let you select it because of that. The Actiontec can also be pretty glitchy about actually doing what you tell it to.

The remote and LAN port in the Actiontec's settings don't do what you think. Remote is the port that the external machine connects to on the Actiontec, and then if you want the Actiontec to redirect it to a different internal port then you enter a different port range in the LAN section.

An example would be remote port 8080, LAN port 80 to get around the port 80 block that Telus does.

So what you need to do is forward 10137 TCP to the LAN IP of the PC you want. If that's not working, welcome to the wonderful world of the Actiontec.

Sometimes a restart can fix it, or it can also do that if you're using a different DHCP server or a static IP. Basically, if you're not getting the DHCP lease from the Actiontec, or if you set a static lease outside of its normal DHCP range.



Shanester

join:2010-10-04
Banff, AB
reply to Shanester

I tried rebooting... no luck.

I know port forwarding works - because it works on another device. I have a Windows Home Server. Since Telus blocks port 80, it's set up on port 8,000. When I'm travelling, I connect to it from port 8,000.

The reason Zend Debugger isn't working (in part) is because it tries to connect to me from a random port. The Actiontec allows me to specify a single remote port... but not the 1,024 - 65,535 range that the debugger uses.

This is the first modem I've ever had that had this restriction.

Shane.
--
Telus High Speed Turbo 15
Actiontec V1000H


ruiner

join:2012-03-10
Canada
reply to Shanester

Almost everything uses a random source port. The remote port is NOT the source port, like I already said it is the port that the external host connects to on your router and is used for redirection if set differently than the internal port.

Why don't you try changing the port that the debugger is using? Or put a FTP or HTTP server on port 10137 and see if it is reachable from the outside.