dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
4201
share rss forum feed

OiCU812
Premium
join:2011-02-21
Murray, KY

TP-Link 3040 Identifies but won't connect

I'm using a usb760/Verizon and trying to setup a tplink 3040 portable router.Connected to Mac osx 10.6.8 via ethernet. Using safari and go to 192.168.0.1 for the tplink installation...all seems to go well but modem won't connect...

Called TP link tech staff and they said to have it dial manually, so I selected that option (#777) as dial # and left APN, user name and password blank... Millenicom says there is no APN, password or username... BTW I did try VZW as password and my modem's number@vzw3g.com as user name and still no go.

Also TP link says make sure PIN is disabled, so VZaccess manager shows nothing in 4 digit pin field (in security section) and modem shows unlocked.

This is part of the system log....WARNING 3G Modem connecting error, please check the dial number and APN.

Any help is appreciated



dib22

join:2002-01-27
Kansas City, MO

Try connecting with the 760 directly connected to the mac, jut to verify that it works fine without the router involved.


OiCU812
Premium
join:2011-02-21
Murray, KY

Thanks Dib, it works fine directly plugged into mac, also works with a cradlepoint 900 and a D-link.... Something I'm not doing right though.... It identifies the 760 but can't seem to connect. This little 3040 is battery powered as well as having a micro usb port to run off a laptop or a power pack... I'm really wanting this thing to work!



dib22

join:2002-01-27
Kansas City, MO

I remember someone having this issue with a Virgin card and and older TP link... I keep searching but can't seem to find it... if I find it, and it has the solution I'll post it here.


Dexter1992

join:2010-07-16
Winona, MN

1 edit
reply to OiCU812

I wonder if you have the same issue I had. My TP-Link: TL-MR3220 V1's factory firmware identified my U598 and connected just fine. I updated to their latest firmware, and the modem is identified but fails to connect. It was clearly their firmware update, I messaged them logs with all the info and they never fixed it. Terrible, I reverted to the last stable firmware build to get my U598 to connect again.

Log when the U598 connects:

####################################################################
# TL-MR3220 System Log
# Time = 2012-06-27 16:58:25 191s
# H-Ver = MR3220 v1 00000000 : S-Ver = 3.12.20 Build 120309 Rel.54030n
# L = 192.168.1.1 : M = 255.255.255.0
# 3G : 3G = 108.100.25.40 : M = 255.255.255.255 : G = 108.100.25.40
####################################################################

Jun 27 16:55:18 OTHER INFO System started
Jun 27 16:55:22 DHCP NOTICE DHCP server started
Jun 27 16:55:22 SECURITY INFO PPTP Passthrough enabled
Jun 27 16:55:22 SECURITY INFO L2TP Passthrough enabled
Jun 27 16:55:22 SECURITY INFO IPSEC Passthrough enabled
Jun 27 16:55:22 SECURITY INFO FTP ALG enabled
Jun 27 16:55:22 SECURITY INFO TFTP ALG enabled
Jun 27 16:55:22 SECURITY INFO H323 ALG enabled
Jun 27 16:55:23 SECURITY INFO RTSP ALG enabled
Jun 27 16:55:43 3G INFO 3G Modem vendorID: 0x1199; productID: 0xfff
Jun 27 16:55:43 3G INFO 3G Modem vendorID: 0x1199; productID: 0xfff
Jun 27 16:55:43 3G INFO 3G Modem vendorID: 0x1199; productID: 0xfff
Jun 27 16:55:43 3G INFO 3G Modem vendorID: 0x1199; productID: 0xfff
Jun 27 16:55:43 3G INFO 3G Modem vendorID: 0x1199; productID: 0xfff
Jun 27 16:55:43 3G INFO 3G Modem vendorID: 0x1199; productID: 0xfff
Jun 27 16:55:43 3G INFO 3G Modem vendorID: 0x1199; productID: 0xfff
Jun 27 16:55:43 3G INFO 3G Modem vendorID: 0x1199; productID: 0xfff
Jun 27 16:55:43 3G INFO 3G Modem vendorID: 0x1199; productID: 0xfff
Jun 27 16:55:44 3G INFO 3G Modem vendorID: 0x1199; productID: 0xfff
Jun 27 16:55:46 DHCP NOTICE DHCPS:Recv DISCOVER from 00:26:F2:A1:79:68
Jun 27 16:55:47 DHCP NOTICE DHCPS:Send OFFER with ip 192.168.1.100
Jun 27 16:55:47 DHCP NOTICE DHCPS:Recv REQUEST from 00:26:F2:A1:79:68
Jun 27 16:55:47 DHCP NOTICE DHCPS:Send ACK to 192.168.1.100
Jun 27 16:55:47 3G INFO Switch modem mode with the 0 command in the file usb_modeswitch.conf
Jun 27 16:55:50 3G INFO 3G Modem vendorID: 0x1199; productID: 0x25
Jun 27 16:55:50 3G INFO 3G Modem vendorID: 0x1199; productID: 0x25
Jun 27 16:55:51 3G INFO 3G Modem vendorID: 0x1199; productID: 0x25
Jun 27 16:56:05 3G INFO Main interface_index[0] = 0
Jun 27 16:56:05 3G INFO Line:926 cmd: modem_scan -d /dev/ttyUSB0 -f "chat -S -V -f /tmp/script" > /tmp/modem_info 2>&1
Jun 27 16:56:07 3G INFO Line 944:
Jun 27 16:56:07 3G INFO Line 944: p2505002,60783 [Oct 22 2008 14:43:01]
Jun 27 16:56:07 3G INFO Line 944: QCOM: SWI6085_FD.00.38
Jun 27 16:56:07 3G INFO Line 944: BOOT: SWI6085_PP.00.50.02 2008/10/22 16:27:34
Jun 27 16:56:07 3G INFO Line 944: APPL: SWI6085_PP.00.50.02 2008/10/22 16:27:34
Jun 27 16:56:07 3G INFO Line 944: USBD: SWI6085_GENERIC.00.00
Jun 27 16:56:07 3G INFO Line 944: SWOC: CDPC_00001_02.04.15
Jun 27 16:56:07 3G INFO Line 944: USB VID: 0x1199 PID: 0x0025
Jun 27 16:56:07 3G INFO Line 944:
Jun 27 16:56:07 3G INFO Line 944: OK
Jun 27 16:56:07 3G INFO Line 944: ATZ
Jun 27 16:56:07 3G INFO Line 944: OK
Jun 27 16:56:07 3G INFO Line 944: AAT+CGMR
Jun 27 16:56:07 3G INFO Line 944: ERROR
Jun 27 16:56:07 3G INFO Line 944: ^MConnect script failed.
Jun 27 16:56:07 3G INFO Line 944: Serial link disconnected.
Jun 27 16:56:07 3G INFO getModemParamByScript 1100 Chip type = 0
Jun 27 16:56:07 3G INFO Line:926 cmd: modem_scan -d /dev/ttyUSB0 -f "chat -S -V -f /tmp/script" > /tmp/modem_info 2>&1
Jun 27 16:56:09 3G INFO Line 944: ATZ
Jun 27 16:56:09 3G INFO Line 944: OK
Jun 27 16:56:09 3G INFO Line 944: AT+GMM
Jun 27 16:56:09 3G INFO Line 953: T598 Rev 1.0 (2)
Jun 27 16:56:09 3G INFO getModemParamByScript 1100 Chip type = 2
Jun 27 16:56:09 3G INFO get_modem_info_file 144 getModemParamByScript return valid type = 2
Jun 27 16:56:09 3G INFO Line:926 cmd: modem_scan -d /dev/ttyUSB0 -f "chat -S -V -f /tmp/script" > /tmp/modem_info 2>&1
Jun 27 16:56:12 3G INFO Line 944:
Jun 27 16:56:12 3G INFO Line 944: T598 Rev 1.0 (2)
Jun 27 16:56:12 3G INFO Line 944:
Jun 27 16:56:12 3G INFO Line 944: OK
Jun 27 16:56:12 3G INFO Line 944: ATZ
Jun 27 16:56:12 3G INFO Line 944: OK
Jun 27 16:56:12 3G INFO Line 944: ATAT+CGMR
Jun 27 16:56:12 3G INFO Line 944: NO CARRIER
Jun 27 16:56:12 3G INFO Line 944: ^MConnect script failed.
Jun 27 16:56:12 3G INFO Line 944: Serial link disconnected.
Jun 27 16:56:12 3G INFO getModemParamByScript 1100 Chip type = 0
Jun 27 16:56:12 3G INFO Line:926 cmd: modem_scan -d /dev/ttyUSB0 -f "chat -S -V -f /tmp/script" > /tmp/modem_info 2>&1
Jun 27 16:56:14 3G INFO Line 944: ATZ
Jun 27 16:56:14 3G INFO Line 944: OK
Jun 27 16:56:14 3G INFO Line 944: AT+CSQ?
Jun 27 16:56:14 3G INFO Line 978: 31, 99
Jun 27 16:56:14 3G INFO Line 944:
Jun 27 16:56:14 3G INFO Line 944: OK
Jun 27 16:56:14 3G INFO Line 944: AT+GMR
Jun 27 16:56:14 3G INFO Line 944: p2505002,60783 [Oct 22 2008 14:43:01]
Jun 27 16:56:14 3G INFO Line 944: QCOM: SWI6085_FD.00.38
Jun 27 16:56:14 3G INFO Line 944: BOOT: SWI6085_PP.00.50.02 2008/10/22 16:27:34
Jun 27 16:56:14 3G INFO Line 944: APPL: SWI6085_PP.00.50.02 2008/10/22 16:27:34
Jun 27 16:56:14 3G INFO Line 944: USBD: SWI6085_GENERIC.00.00
Jun 27 16:56:14 3G INFO Line 944: SWOC: CDPC_00001_02.04.15
Jun 27 16:56:14 3G INFO Line 944: USB VID: 0x1199 PID: 0x0025
Jun 27 16:56:14 3G INFO Line 944:
Jun 27 16:56:14 3G INFO Line 944: OK^M
Jun 27 16:56:14 3G INFO Line 944: Serial connection established.
Jun 27 16:56:14 3G INFO Line 944: Serial link disconnected.
Jun 27 16:56:14 3G INFO getModemParamByScript 1100 Chip type = 2
Jun 27 16:56:14 3G INFO get_modem_info_file 159 getModemParamByScript return valid type = 2
Jun 27 16:56:14 3G INFO Line:926 cmd: modem_scan -d /dev/ttyUSB0 -f "chat -S -V -f /tmp/script" > /tmp/modem_info 2>&1
Jun 27 16:56:16 3G INFO Line 944:
Jun 27 16:56:16 3G INFO Line 944: 31, 99
Jun 27 16:56:16 3G INFO Line 944:
Jun 27 16:56:16 3G INFO Line 944: OK
Jun 27 16:56:16 3G INFO Line 944: ATZ
Jun 27 16:56:16 3G INFO Line 944: OK
Jun 27 16:56:16 3G INFO Line 944: ATAT+CGMR
Jun 27 16:56:16 3G INFO Line 944: NO CARRIER
Jun 27 16:56:16 3G INFO Line 944: ^MConnect script failed.
Jun 27 16:56:16 3G INFO Line 944: Serial link disconnected.
Jun 27 16:56:16 3G INFO getModemParamByScript 1100 Chip type = 1
Jun 27 16:56:16 3G INFO get_modem_info_file 170 getModemParamByScript return valid type = 1
Jun 27 16:56:16 3G INFO get_modem_info_file 185 Return chip type = 1
Jun 27 16:56:16 3G INFO Get modem info: minfo.modemChipType = 1, modemName = T598 Rev 1.0 (2), modemSignalQua=100, minfo.simLock = 5
Jun 27 16:56:16 3G INFO 3G Modem vendorID: 0x1199; productID: 0x25
Jun 27 16:56:16 3G INFO USB modem is ready
Jun 27 16:56:32 PPP WARNING 3G disconnected
Jun 27 16:57:07 PPP NOTICE Standard authentication.
Jun 27 16:57:07 3G INFO Run 3G dial cmd: pppd /dev/ttyUSB0 115200 connect "chat -s -v -f /etc/ppp/conn-s
Jun 27 16:57:29 3G NOTICE 3G Modem connecting error, please check the dial number and APN.
Jun 27 16:57:31 3G INFO mobileCmdReq 290 mobileFormatCmd error
Jun 27 16:57:52 PPP NOTICE Standard authentication.
Jun 27 16:57:52 3G INFO Run 3G dial cmd: pppd /dev/ttyUSB0 115200 connect "chat -s -v -f /etc/ppp/conn-s
Jun 27 16:57:54 DHCP NOTICE DHCPS:Recv INFORM from 00:26:F2:A1:79:68
Jun 27 16:57:57 PPP INFO sent [LCP Req mru=1480 asyncmap=0x0 magic=0x16eff3c]
Jun 27 16:57:57 PPP INFO rcvd [LCP Req asyncmap=0x0 magic=0xa06d6308 pcomp accomp]
Jun 27 16:57:57 PPP INFO sent [LCP Rej pcomp accomp]
Jun 27 16:57:57 PPP INFO rcvd [LCP Rej mru=1480]
Jun 27 16:57:57 PPP INFO sent [LCP Req asyncmap=0x0 magic=0x16eff3c]
Jun 27 16:57:57 PPP INFO rcvd [LCP Req asyncmap=0x0 magic=0xa06d6308]
Jun 27 16:57:57 PPP INFO sent [LCP Ack asyncmap=0x0 magic=0xa06d6308]
Jun 27 16:57:57 PPP INFO rcvd [LCP Nak pcomp accomp]
Jun 27 16:57:57 PPP INFO sent [LCP Req asyncmap=0x0 magic=0x16eff3c]
Jun 27 16:57:57 PPP INFO rcvd [LCP Nak pcomp accomp]
Jun 27 16:57:57 PPP INFO sent [LCP Req asyncmap=0x0 magic=0x16eff3c]
Jun 27 16:57:57 PPP INFO rcvd [LCP Nak pcomp accomp]
Jun 27 16:57:57 PPP INFO sent [LCP Req asyncmap=0x0 magic=0x16eff3c]
Jun 27 16:57:57 PPP INFO rcvd [LCP Ack asyncmap=0x0 magic=0x16eff3c]
Jun 27 16:57:57 PPP INFO sent [IPCP Req compress VJ 0f 01 addr=0.0.0.0 dns1=0.0.0.0 dns3=0.0.0.0]
Jun 27 16:57:57 PPP INFO rcvd [LCP DiscReq magic=0xa06d6308]
Jun 27 16:57:57 PPP INFO rcvd [IPCP Req addr=68.28.145.69]
Jun 27 16:57:57 PPP INFO sent [IPCP Ack addr=68.28.145.69]
Jun 27 16:57:57 PPP INFO rcvd [IPCP Rej compress VJ 0f 01]
Jun 27 16:57:57 PPP INFO sent [IPCP Req addr=0.0.0.0 dns1=0.0.0.0 dns3=0.0.0.0]
Jun 27 16:57:57 PPP INFO rcvd [IPCP Nak addr=108.100.25.40 dns1=68.28.138.132 dns3=68.28.137.132]
Jun 27 16:57:57 PPP INFO sent [IPCP Req addr=108.100.25.40 dns1=68.28.138.132 dns3=68.28.137.132]
Jun 27 16:57:57 PPP INFO rcvd [IPCP Ack addr=108.100.25.40 dns1=68.28.138.132 dns3=68.28.137.132]
Jun 27 16:58:03 3G NOTICE 3G connected

Log when the U598 does not connect:

####################################################################
# TL-MR3220 System Log
# Time = 2000-01-01 0:02:01 122s
# H-Ver = MR3220 v1 00000000 : S-Ver = 3.12.20 Build 120523 Rel.38790n
# L = 192.168.1.1 : M = 255.255.255.0
# 3G : 3G = 0.0.0.0 : M = 0.0.0.0 : G = 0.0.0.0
####################################################################

1st day 00:00:04 OTHER INFO System started
1st day 00:00:08 DHCP NOTICE DHCP server started
1st day 00:00:08 SECURITY INFO PPTP Passthrough enabled
1st day 00:00:08 SECURITY INFO L2TP Passthrough enabled
1st day 00:00:08 SECURITY INFO IPSEC Passthrough enabled
1st day 00:00:08 SECURITY INFO FTP ALG enabled
1st day 00:00:08 SECURITY INFO TFTP ALG enabled
1st day 00:00:09 SECURITY INFO H323 ALG enabled
1st day 00:00:09 SECURITY INFO RTSP ALG enabled
1st day 00:00:24 DHCP NOTICE DHCPS:Recv DISCOVER from 00:26:F2:A1:79:68
1st day 00:00:25 DHCP NOTICE DHCPS:Send OFFER with ip 192.168.1.100
1st day 00:00:28 DHCP NOTICE DHCPS:Recv DISCOVER from 00:26:F2:A1:79:68
1st day 00:00:28 DHCP NOTICE DHCPS:Send OFFER with ip 192.168.1.100
1st day 00:00:28 DHCP NOTICE DHCPS:Recv DISCOVER from 00:26:F2:A1:79:68
1st day 00:00:28 DHCP NOTICE DHCPS:Send OFFER with ip 192.168.1.100
1st day 00:00:28 DHCP NOTICE DHCPS:Recv REQUEST from 00:26:F2:A1:79:68
1st day 00:00:28 DHCP NOTICE DHCPS:Send ACK to 192.168.1.100
1st day 00:00:31 3G INFO 3G Modem vendorID: 0x1199; productID: 0xfff
1st day 00:00:31 3G INFO 3G Modem vendorID: 0x1199; productID: 0xfff
1st day 00:00:31 3G INFO 3G Modem vendorID: 0x1199; productID: 0xfff
1st day 00:00:31 3G INFO 3G Modem vendorID: 0x1199; productID: 0xfff
1st day 00:00:31 3G INFO 3G Modem vendorID: 0x1199; productID: 0xfff
1st day 00:00:31 3G INFO 3G Modem vendorID: 0x1199; productID: 0xfff
1st day 00:00:31 3G INFO 3G Modem vendorID: 0x1199; productID: 0xfff
1st day 00:00:31 3G INFO 3G Modem vendorID: 0x1199; productID: 0xfff
1st day 00:00:31 3G INFO 3G Modem vendorID: 0x1199; productID: 0xfff
1st day 00:00:31 3G INFO 3G Modem vendorID: 0x1199; productID: 0xfff
1st day 00:00:31 3G INFO 3G Modem vendorID: 0x1199; productID: 0xfff
1st day 00:00:32 3G INFO 3G Modem vendorID: 0x1199; productID: 0xfff
1st day 00:00:36 3G INFO Switch modem mode with the 0 command in the file usb_modeswitch.conf
1st day 00:00:39 3G INFO 3G Modem vendorID: 0x1199; productID: 0x25
1st day 00:00:39 3G INFO 3G Modem vendorID: 0x1199; productID: 0x25
1st day 00:00:40 3G INFO 3G Modem vendorID: 0x1199; productID: 0x25
1st day 00:00:48 3G INFO Main interface_index[0] = 0
1st day 00:00:50 3G INFO getModemParamByScript 1135 Chip type = 0
1st day 00:00:53 3G INFO getModemParamByScript 1135 Chip type = 2
1st day 00:00:53 3G INFO get_modem_info_file 144 getModemParamByScript return valid type = 2
1st day 00:00:55 3G INFO getModemParamByScript 1135 Chip type = 1
1st day 00:00:55 3G INFO get_modem_info_file 155 getModemParamByScript return valid type = 1
1st day 00:00:57 3G INFO getModemParamByScript 1135 Chip type = 0
1st day 00:01:00 3G INFO getModemParamByScript 1135 Chip type = 0
1st day 00:01:00 3G INFO get_modem_info_file 180 Can not get modem PIN status
1st day 00:01:00 3G INFO get_modem_info_file 185 Return chip type = 0
1st day 00:01:00 3G INFO Get modem info: minfo.modemChipType = 0, modemName = T598 Rev 1.0 (2), modemSignalQua=100, minfo.simLock = 5
1st day 00:01:00 3G INFO 3G Modem vendorID: 0x1199; productID: 0x25
1st day 00:01:00 3G INFO USB modem is ready
1st day 00:01:17 PPP NOTICE Standard authentication.
1st day 00:01:17 3G INFO Run 3G dial cmd: pppd /dev/ttyUSB0 115200 connect "chat -s -v -f /etc/ppp/conn-s
1st day 00:01:36 3G NOTICE 3G Modem connecting error, please check the dial number and APN.
1st day 00:01:38 3G INFO mobileCmdReq 270 mobileFormatCmd error
1st day 00:01:56 PPP NOTICE Standard authentication.
1st day 00:01:56 3G INFO Run 3G dial cmd: pppd /dev/ttyUSB0 115200 connect "chat -s -v -f /etc/ppp/conn-s


OiCU812
Premium
join:2011-02-21
Murray, KY
reply to OiCU812

"Solved" .....thanks to Dexter.....I went in and flashed the older firmware I found at tp-link's site and it worked like a charm... Obviously the new firmware (march of this year) wasn't tested with a Verizon 760..

Note: Tech support at TP-Link is almost non-existant... 3 phone calls to people who were trying hard but can't speak english well enough to communicate... Web site was even worse... they just don't respond at all.. I registered with their forum and got no help at..... just telling me I had to fill in a APN and a correct dial#..

Thanks again, I do appreciate the help!


Dexter1992

join:2010-07-16
Winona, MN

said by OiCU812:

"Solved" .....thanks to Dexter.....I went in and flashed the older firmware I found at tp-link's site and it worked like a charm... Obviously the new firmware (march of this year) wasn't tested with a Verizon 760..

Note: Tech support at TP-Link is almost non-existant... 3 phone calls to people who were trying hard but can't speak english well enough to communicate... Web site was even worse... they just don't respond at all.. I registered with their forum and got no help at..... just telling me I had to fill in a APN and a correct dial#..

Thanks again, I do appreciate the help!

Glad to hear your problem was fixed. This is odd, it seems the latest firmware breaks compatibility. I will e-mail them again the logs and reference this page. Last time I did, the person talking to me could not understand my text, like you said. I recently bought a TP Link: TL-WR-1043ND and flashed it with DD-WRT firmware. For $50, the TP-Link router is a steal, with it's 8MB flash. I can put DD-WRT's latest builds on, and they include 3G support. Connected my U598, and it connected no problem. It destroys my MBR-1000 and I paid nearly $200 for it. I spend $50 on the TP-Link model, and with DD-WRT I get A LOT more performance than my MBR-1000. Features such as UPnP actually work 100% of the time, and can do things the MBR-1000 can't. Wifi is 100% in the entire house now . And I am getting faster speeds:



Dexter1992

join:2010-07-16
Winona, MN

I also find that if I set my U598 to NDIS mode and to search for Sprint only networks I can achieve greater consistent speeds. Since the router uses a driver, NDIS mode gives it the most compatibility with the router.




Upload finally reached over the 0.50Mbps cap after doing so.