dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
976
share rss forum feed


Cheese
Premium
join:2003-10-26
Naples, FL
kudos:1

TF2 closing

Anyone who plays TF2 having issues with it closing by itself when alt tabbed out? It appears to have been since the last update. There are no errors or anything.

The steam forums are absolutely worthless for any kind of help.


brianiscool

join:2000-08-16
Tampa, FL
kudos:1

Do you have a ATI card?



Cheese
Premium
join:2003-10-26
Naples, FL
kudos:1

said by brianiscool:

Do you have a ATI card?

Yep, but this didn't start until just after this last update.


BigBlarg

join:2008-02-10
Longueuil, QC
kudos:1
reply to Cheese

I've been having a lot of problem in the past with TF2.

I started running it in windowed mode, no border, at native resolution and the problems were gone.

This way you can alt-tab out and come back much faster too.



Cheese
Premium
join:2003-10-26
Naples, FL
kudos:1

It's not that it doesn't work, the game just closes all together, no errors messages, nothing, it's worked for years just fine this way.

Had some dolt troll on steam forums tell me "it's not supported"...

lol

And it didn't start until this last update

I usually join the game on my notebook at work and idle all day but now, it just randomly closes and is quite annoying.


brianiscool

join:2000-08-16
Tampa, FL
kudos:1
reply to Cheese

ATI is notrious known for this issue. Their drivers are buggy. I suggest going back to the old drivers. If you really want the latest try reinstalling .



Cheese
Premium
join:2003-10-26
Naples, FL
kudos:1

It happens on a notebook and pc, notebook has a nvidia card, and the machine with the AMD card, hasn't had updates prior to this happening.

I highly doubt it's an AMD issue since it started after the last TF2 update, and another issue that happens now too, is if I double click a server to join, it starts the game but doesn't join the server, I have to force it to join the server once the game is loaded. Didn't do that before the update either.



nope

@anonymouse.org
reply to brianiscool

Its not an ati or amd bug, their drivers are perfectly fine. This is a tf2 update issue.



Cheese
Premium
join:2003-10-26
Naples, FL
kudos:1
reply to Cheese

Did a clean install on my notebook and still happening... sigh...

sick of these updates valve puts out breaking shit...



BigBlarg

join:2008-02-10
Longueuil, QC
kudos:1
reply to Cheese

Still, give it a try.

I think you must add something like "-windowed -noborder" in the launch command of TF2 in Steam.

Do a quick Google search and you should find an answer.



Cheese
Premium
join:2003-10-26
Naples, FL
kudos:1

When it broke after an update, I shouldn't have to change anything

I don't want to run it windowed, never had to for years.



BigBlarg

join:2008-02-10
Longueuil, QC
kudos:1
Reviews:
·ELECTRONICBOX

2 edits
reply to Cheese

Then what do you want? Why are you posting this here?

I'm offering you a solution. You don't even want to try it.

I would say that you are lucky if problems only started for you since the last update.

Making the game run in a borderless window at your desktop resolution is pretty much running the game in fullscreen except it's window mode instead. Also, for some reason, it is known to fix many weird problem related to TF2 crashing/closing.

Edit : »forums.steampowered.com/forums/s···=1929378

You can also add -novid to skip the intro video.

It takes less than 5 minutes and it is fixed forever*.

* or until you reinstall Steam



Cheese
Premium
join:2003-10-26
Naples, FL
kudos:1

Why am I posting here? This is a public forum? Looking for help? Offering a "solution" of running in a window and borderless, not a solution that works for me.

If the issue hasn't occurred since I started playing TF2 in 07, I shouldn't need to change my settings.

When something is broke, it's broke.



BigBlarg

join:2008-02-10
Longueuil, QC
kudos:1
Reviews:
·ELECTRONICBOX

4 edits
reply to Cheese

Edit : Wow.. what's wrong with you?

Did you even try it? The solution I suggested you will give you exactly the same feeling as if you were playing in fullscreen mode and it's probably the easiest thing to apply that can help you.

Why is it not a solution that works for you?

If you don't want to change any settings, what kind of solution are you looking for?

I could suggest you to clap your hands twice at midnight on a full moon but sadly, magic doesn't exist.

If you don't want to change any setting to get fix your problem, GTFO. You are only wasting people's time. Valve doesn't read these forums.



C0deZer0
Oc'D To Rhythm And Police
Premium
join:2001-10-03
Tempe, AZ
reply to BigBlarg

said by BigBlarg:

I've been having a lot of problem in the past with TF2.

I started running it in windowed mode, no border, at native resolution and the problems were gone.

This way you can alt-tab out and come back much faster too.

I'd be interested to know what kind of settings you'd need to change to enable that.
--
Because, f*ck Sony


Cheese
Premium
join:2003-10-26
Naples, FL
kudos:1
reply to BigBlarg

It's not a solution to the problem It's a work around and one I am not going to do and should not need to do. This was obviously an issue with the update

Comprende? Also, I don't need attitude either from someone telling me "they gave me a solution" when it's not a "solution"...



BigBlarg

join:2008-02-10
Longueuil, QC
kudos:1
Reviews:
·ELECTRONICBOX

Alright. I still don't understand what weird stuff is going on in your head but fine.

Go away, stop wasting our time. No one can give you a solution. I'm pretty sure you can only get some other kind of workaround like this on these forums.

Contact Valve, they're the only one who can give you the solution : a patch.



Cheese
Premium
join:2003-10-26
Naples, FL
kudos:1

Wasting your time? This is a PUBLIC forum. YOU don't have to READ the post. Period.

If you don't like it, don't read or respond