dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1571
share rss forum feed

moffa

join:2007-10-14
Ajax, ON

[Internet] Tomato and Sagemcom 2864 - anyone have it working?

Does anyone have Tomato working with this modem on VDSL? I am only getting a local IP address and trying to troubleshoot. I was just wondering if anyone has it working as I can't seem to get it working.



coaxguy

join:2009-07-29
kudos:1

Re: [Internet] Tomato and Sagemcom 2864 - anyone have it working

Are you talking about putting tomato on the Sagemcom? If so it's not possible. Tomato needs a Broadcom chipset to function which the Sagemcom does not have.


moffa

join:2007-10-14
Ajax, ON

No I mean Tomato on my E4200 and trying to use the Sagemcom in bridge mode. dd-wrt seems to work but tomato doesn't. I can't figure it out.


Bestman

join:2005-04-05
Quebec, QC
reply to moffa

Yes, I've got it working, but NOT in bridge mode.
Since a few weeks or so, it does not seem to be possible to connect my Tomato router in PPPoE. But I've got it working correctly in DHCP mode, and putting my Tomato router in the DMZ of the Sagemcom.
I hope I make sense to you, I could give more details if needed.


Bplayer

join:2012-06-28
Thornhill, ON
Reviews:
·Bell Fibe
reply to moffa

It is working with my WRT54GL router. I have it configured to provide PPPoE, but I gather that this may be blocked at some point. I also have the 2864 doing so that that apps work on the PVR, but I am not really using them. WPA and Wireless are turned off on the 2865.


Cloneman

join:2002-08-29
Montreal
kudos:4
reply to moffa

put your pppoe login credentials in the E4200, and remove them from the Sagemcom


Bestman

join:2005-04-05
Quebec, QC

said by Cloneman:

put your pppoe login credentials in the E4200, and remove them from the Sagemcom

That doesn't work for me anymore. By the way, I'm on FTTH, if it makes a difference.

Plus, if you remove the PPPoE credentials from the Sagemcom, you'll lose the Internet capabilities from the your TV apps. This may or may not matter to you, though.


Frank_IT
Premium
join:2003-11-01
Montreal

for me, that way work fine. On FTTH too.
--
Rogers - iPhone 4s 32gb


Fernboy61

join:2011-11-23
Quebec, QC

It still doesn't work for me and I, too, have an E4200.


moffa

join:2007-10-14
Ajax, ON
reply to Cloneman

I removed the pppoe credentials from the Sagemcom but Tomato only gives me the lan ip address (i.e. 192.168.1.1) on the wan interface. I'm also trying on bridge mode with fttn without TV.

Strangely ddwrt works fine.



Rigor_M

join:2010-09-26
Quebec, QC
reply to Frank_IT

said by Frank_IT:

for me, that way work fine. On FTTH too.

Did you get it working with PPPoE in your personal router + TV (like we talked in other posts) ?


archiso

@bell.ca
reply to moffa

tomato+bellbox

I am using this ever since I have Bell.

On the Tomato router, Basic | Network | WAN set to DHCP and manual MTU 1500
In Advanced | Routing
[fixed]192.168.2.0 * 255.255.255.0 0 vlan1 (WAN)[/fixed] so you can connect to the modem from your network, saves a lot of cable connecting disconnecting when troubleshooting

Now on the bellbox side
Settings | Network
DHCP Enabled
Router IP 192.168.2.1
Mask 255.255.255.0
Range 192.168.2.10 to 192.168.2.20 (doesn't really matter how large is your DHCP pool because only the Tomato router will use it to get an address on its WAN port)
Make a DHCP reservation for your Tomato router using its MAC.
Set DMZ to enabled and to your Tomato WAN port IP

Wireless:
Disable everything. Especially WPS. You will use your Tomato wifi anyway so better shut the bellbox off, less microwaves in the air. Besides, reaver cracks open your bellbox wifi in minutes with WPS on.

Internet:
Put your bell credentials. Edit DNS if need be and set a hostname if you like.

Save + restart everything and you're good to go. Works for me.



Rigor_M

join:2010-09-26
Quebec, QC

said by archiso :

I am using this ever since I have Bell.

On the Tomato router, Basic | Network | WAN set to DHCP and manual MTU 1500
In Advanced | Routing
[fixed]192.168.2.0 * 255.255.255.0 0 vlan1 (WAN)[/fixed] so you can connect to the modem from your network, saves a lot of cable connecting disconnecting when troubleshooting

...

Save + restart everything and you're good to go. Works for me.

Yeah, thats a basic way of doing it but actually, your doing double nating wich you could have problems down the road.. (i know that Voip is not to thrilled with double nating)

We used to be able to get a public IP on the personal router behind bell's router (using a bridged method). I'm not going to settle for less

moffa

join:2007-10-14
Ajax, ON

1 edit
reply to moffa

Re: [Internet] Tomato and Sagemcom 2864 - anyone have it working

Under WAN / Internet, in the Options box add:

noipdefault

-That's all, now it works and no double NAT



Rigor_M

join:2010-09-26
Quebec, QC

said by moffa:

Under WAN / Internet, in the Options box add:

noipdefault

-That's all, now it works and no double NAT

That option must be in tomato because i've never seen it the sagemcom.

moffa

join:2007-10-14
Ajax, ON

Yes that is correct.