dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
12380
share rss forum feed


viperm
Carpe Diem
Premium
join:2002-07-09
Winchester, CA

PPTP connection no default gateway given from Mikrotik

I have setup a PPTP connection on my sites as usual and I can log in and manage devices but for some reason its not giving me a default gateway. (desktop PC running windows 7)

I.E devices are 10.10.2.0/24 subnet I get an address of 10.10.2.200 subnet 255.255.255.255??

The gateway should be 10.10.2.1 on the Tik but no gateway is given to my PC so I cant get out to the net? I run a tracert route from the devices I am managing and they seem to get out just fine. When connected I can PING from my PC out thru the tik to the net but no browsing etc. I am also getting DNS info correctly from the TIK so I dont think its a DNS issue even though it almost appears that way not sure why pings go thru but no DNS request make it thru when PPTP connection is active.

Any Ideas? for the life of me I cant find or remember how to tell the Tik PPTP settings to give the default gateway of the tik to any PPTP users or accounts.

I have done this many times before on TIKS I no longer manage but cant seem to put my finger on it..

Thanks
--
»www.accelwireless.com
ComTrain Certified Tower Climber.
Wireless and IT consultant.
Proficient in Mikrotik


Inssomniak
The Glitch
Premium
join:2005-04-06
Cayuga, ON
kudos:2
The /32 subnet is normal for a point to point connection.
Still sounds like a DNS problem

Ipconfig /all
--
OptionsDSL Wireless Internet
»www.optionsdsl.ca


viperm
Carpe Diem
Premium
join:2002-07-09
Winchester, CA
I did and like I stated earlier I only get an IP 10.10.2.200 subnet 255.255.255.255 and correct DNS info but no gateway given out to me on the PC but if I did not get a gateway how am I able to ping.

IP config /all shows above info except gateway of 0.0.0.0

Thanks
--
»www.accelwireless.com
ComTrain Certified Tower Climber.
Wireless and IT consultant.
Proficient in Mikrotik

bburley

join:2010-04-30
Cold Lake, AB
The gateway given to dhcp clients is in "/ip dhcp-server network" as well as the DNS servers to be given out.

The IP address in there should have the subnet mask /24 appended.


Inssomniak
The Glitch
Premium
join:2005-04-06
Cayuga, ON
kudos:2
I think he is talking about PPP

The "local address" in the ppp profile sets the computers gateway when a
PPP connection is made
--
OptionsDSL Wireless Internet
»www.optionsdsl.ca


viperm
Carpe Diem
Premium
join:2002-07-09
Winchester, CA
Yes PPP session. DHCP to clients works fine

bburley

join:2010-04-30
Cold Lake, AB
I didn't read carefully enough.

I am not sure if Windows 7 is the same, but check the TCP/IPv4 properties and click the advanced button near "Obtain DNS server address automatically" and see if it has a checkbox for "Use default gateway on remote network"


viperm
Carpe Diem
Premium
join:2002-07-09
Winchester, CA
It has use default gateway on remote router and its checked. The problem is the Mikrotik is not announcing the default gateway to the PPP client on only IP, Subnet and DNS.

That's the part I am trying to figure out.

bburley

join:2010-04-30
Cold Lake, AB
Is it the "Routes" box for each user under Secrets?


Ant

join:2013-03-15
Clanton, AL
Reviews:
·MegaPath

1 edit
In the Mikrotik, under PPP, Profiles, check the profile for the PPTP connection, and make sure the remote address is set to the correct ip pool.

If that checks out, look at ip, DHCP server, under networks.

When you only get an ip and subnet, how are you connecting? In windows, are you sort of double authenicating? Sorry I'm having a difficult time explaining. Are you just turning the computer on and letting it get an ip and trying to browse or have you set it up to actually do the ppp handshake to be authenticated to the vpn/pppoe network?


viperm
Carpe Diem
Premium
join:2002-07-09
Winchester, CA
I have looked at all that time and time again nothing looks abnormal..

I have started from scratch. Ether2 is hooked to nothing on this RB433AH. I assigned it 10.0.4.1 as the ip.

Set up a dhcp server on that interface with gateway, DNS network etc.

Works perfect when I connect physically to it . So not in my profile I set up the local IP as 10.0.4.1 (mikrotik) then I set remote address to DHCP pool 2 which is the pool for 10.0.4.0 subnet.

What's funny is I get an ip address from the pool but no gateway as usual but looking at the IP leases it never shows that it gave out an IP to me via PPP.

FYI it does not appear to be the routes box in secrets I put in 10.0.4.1 but still nothing handed out to me as far as gateway on PPP session.

--
»www.accelwireless.com
ComTrain Certified Tower Climber.
Wireless and IT consultant.
Proficient in Mikrotik

bburley

join:2010-04-30
Cold Lake, AB
In PPTP Client under 'Dial Out' there is a checkbox for Add Default Route. I am not that familiar with it, though.

If control of the default route is in the above client settings, does that mean that it would be under the control of the PC client?

bburley

join:2010-04-30
Cold Lake, AB
reply to viperm
This might shed some light on the issue.

»forum.mikrotik.com/viewtopic.php?f=2&t=10405


viperm
Carpe Diem
Premium
join:2002-07-09
Winchester, CA
reply to bburley
Are you talking on windows 7? I have a tab that says general and under it I have a box that says dial another connection first. It is not checked but I think that has to do with actual dial up connection not VPN?

Under same settings networking tab I have a general and advanced button but nothing that gives me a add default route only "USE default gateway on remote network"

--
»www.accelwireless.com
ComTrain Certified Tower Climber.
Wireless and IT consultant.
Proficient in Mikrotik


Inssomniak
The Glitch
Premium
join:2005-04-06
Cayuga, ON
kudos:2
Did you try another computer?

Sounds like you have it set up right.
EDIT:

Is this PC thats dialing in to the PPTP server also the same one getting an DHCP lease from the same router?
That could be your issue, as it already has that gateway installed into the routes table as your default gateway.?

--
OptionsDSL Wireless Internet
»www.optionsdsl.ca


viperm
Carpe Diem
Premium
join:2002-07-09
Winchester, CA
Not yet I am going to try my laptop later today when I have some free time..

Will post the results. I am trying to chase down an issue with logging into the UBNT gear at the tower or backhaul site. When using Firefox or IE it comes back all jumbled and out of frame etc.

If I do a Nat port forward from the public interface to the private IP of the radio it all works fine perfect GUI interface.

If using VPN its all jacked up and I don't want to change any settings for fear of having something checked I don't want checked and it saves and I am locked out or lose connection etc.

For example the AP is set up as AP mode USA. When logging in via VPN it says its in client mode with Canada as the country? hitting other tabs it displays half info or no info at all.. I have tried turning off firewall on PC and everything on this end but no luck..
--
»www.accelwireless.com
ComTrain Certified Tower Climber.
Wireless and IT consultant.
Proficient in Mikrotik


Inssomniak
The Glitch
Premium
join:2005-04-06
Cayuga, ON
kudos:2
said by viperm:

For example the AP is set up as AP mode USA. When logging in via VPN it says its in client mode with Canada as the country? hitting other tabs it displays half info or no info at all.. I have tried turning off firewall on PC and everything on this end but no luck..

this sounds like an MTU problem.
--
OptionsDSL Wireless Internet
»www.optionsdsl.ca


viperm
Carpe Diem
Premium
join:2002-07-09
Winchester, CA

2 edits
HMMM interesting where or what should the MTU be set to? and on what interface?

Currently all physical and bridge interfaces show set to 1500..

When I have a PPP Session going I look at Interface info and it shows my PPP connection and its connected at an MTU rate of 1400? Is that normal or should it be higher? If so where can I adjust it since my settings on that Mikrotik unit all interfaces show 1500 for MTU

Mike_27
Premium
join:2004-05-15
Gardiner, MT

1 edit
if all of your interfaces support packets larger than 1500 you can set the mtu to greater than 1492.

[admin@mikrotik] > interface pppoe-server server print detail 
Flags: X - disabled 
 0   service-name="your_service" interface=ether1 max-mtu=1492 
     max-mru=1492 mrru=disabled authentication=pap,chap,mschap1,mschap2 
     keepalive-timeout=20 one-session-per-host=yes max-sessions=0 
     default-profile=residential-01500k/256k
 
ok, after reading it again i'm confused, but,

[admin@mikrotik] > interface pptp-server server print detail
 
will be similar.

bburley

join:2010-04-30
Cold Lake, AB
reply to viperm
This article shows how to test MTU on a PPTP link.

»portal.cyberpro.com.au/tips/Opti···MTU.html


viperm
Carpe Diem
Premium
join:2002-07-09
Winchester, CA
reply to viperm
Click for full size
Click for full size
First attachment is before MTU change and 2nd is after setting to 1470 from 1450 after reading the how to test mtu setting in previous post..

I am at a loss this has me scratching my head..