dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
12931
share rss forum feed

Shootist
Premium
join:2003-02-10
Decatur, GA
kudos:3

Method for using a wireless router as AP

This topic is for all looking to use a wireless router as just a access point and use a regular wired only router as there main connection to there LAN and the Internet.

There are 3 things you must do for this to work.
1. Change the the wireless router IP address.
2. Disable the DHCP server on the wireless router.
3. Don't use the WAN/Internet port on the wireless router.

This is how I have done it.

Connect (wire) a PC to 1 of the Wireless router's LAN port all by it self. Turn on, plug in, the router and boot the PC.
Open Internet Explorer and in the address bar type in the IP address of the wireless router to get to the setup pages, the IP address can be found in the documentation that came with the wireless router. Once there find the section where you can change the router's IP address. Now you must know the IP address of your main router and the IP address must be changed on the wireless to be in the same subnet as the main router and have a different address than the main router. If your main router has a IP of 192.168.1.1 with a subnet mask of 255.255.255.0 then you must change the wireless router IP to 192.168.1."something other than 1". I use one digit higher than the main router. So my main router has a IP of 192.168.1.1 and the wireless router has a IP of 192.168.1.2, these 2 IP addresses are in the same subnet.
Now once you change the routers IP address you will loose the connection to the wireless router, that's OK. Type in the new IP address of the router in the address bar of IE. This will bring you back to the routers setup pages. Find the section that controls the DHCP server and disable it. You are now done changing all the setting on the wireless router. Turn off the PC and the router.
Reconnect the PC you were using to configure the wireless router back the way you had it before you started. Now connect from a LAN port of your main router to a LAN port of the wireless router. If the main router is off turn it on, turn on the wireless router and start a PC wired to the main router. Once everything is running, PC has booted to the desktop, open IE and enter first the IP address of the main router, this is to make sure you can still access it. Then type in the IP address of the wireless router, again to make sure you can access it. If you can get to both routers you are done (almost). Now you need to setup the wireless side of the wireless router. That setup is up to you. Also you might want to change the access password on the wireless router, that's up to you.

I hope this helps people looking to use a wireless router as just a wireless access point.
--
Are You Ready--Stand By BEEP ********


GeekNJ
Premium
join:2000-09-23
Waldwick, NJ
Reviews:
·Optimum Online
·Verizon FiOS
And here's the steps I used to configure a BEFW11S4 as an access point connected to another BEFSR41 router - »connect 2 linksys routers
--
Have you tweaked your OOL connection?

DSLJohnny

join:2001-01-25
Jasper, GA
reply to Shootist
I would actually suggest a different approach, shown here. It puts the wireless on a different network, so it is not as easy to see into the wired network. ....slightly... more secure ifyou do not implement all the security precautions.
»www.pccitizen.com/correctwireless.htm
J


dg2

@fyvlar.swbell.ne
reply to Shootist
With some routers, you may have to make the connection using a crossover cable. If you use a regular cable and don't get an activity light on your original (wired-only) router, try using a crossover.

Shootist
Premium
join:2003-02-10
Decatur, GA
kudos:3
reply to DSLJohnny
said by DSLJohnny:
I would actually suggest a different approach, shown here. It puts the wireless on a different network, so it is not as easy to see into the wired network. ....slightly... more secure ifyou do not implement all the security precautions.
»www.pccitizen.com/correctwireless.htm
J

The whole idea of my post was to help someone that is not that familiar with networking but needs or wants to have a wireless connection for there LAN and already has a router setup that they are using for a BB connection and has or is going to buy a second router that is wireless. Although your suggestion might be more secure, which I don't think it is because the the wireless router that is the second in the chain of router can still access the first router and all the PC on the LAN connected to the first router and the BB connection(this was pointed out to you in your original post on this topic), it is much more difficult to setup and you have the problem of having 2 LAN segments that is not easy to share files across and isn't that what a LAN is all about.
--
Are You Ready--Stand By BEEP ********

Shootist
Premium
join:2003-02-10
Decatur, GA
kudos:3
reply to dg2
said by dg2:
With some routers, you may have to make the connection using a crossover cable. If you use a regular cable and don't get an activity light on your original (wired-only) router, try using a crossover.

Yes you are right BUT most newer model routers have auto-configuring port, straight through or crossover (that's why you don't see many new models with uplink ports). So even if your original router doesn't have the auto switching port the new one will, which is all you need.
--
Are You Ready--Stand By BEEP ********


Anav
Sarcastic Llama? Naw, Just Acerbic
Premium
join:2001-07-16
Dartmouth, NS
kudos:5
reply to Shootist
Concur with shootist on the cascading of wireless router.
It would actually be better to have the wireless on the first router and the more secure stuff behind the second cascaded router. Either way you have two separate lans which defeats sharing of stuff at the home.
Much better on the wireless side to
a. use 802.1x encrypted authentication to prevent access to the wifi circuit and
b. some sort on actual data packet encryption, WEP, dynamic WEP, WPA PSK, WPA1-tkip, WPA2-ccmp.
--
Ain't nuthin but the blues! "Albert Collins". Leave your troubles at the door! "Pepe Peregil". Just Don't Wifi without WPA, "Yul Brenner"


Chizep
Premium
join:2002-04-07
Concord, NC

1 edit
reply to Shootist
Great thread Shootist See Profile! This is not something the average user would know how to do. I'm sure a lot of people are now getting wireless routers and think this has to replace that "old" wired router.

said by Shootist:

2. Disable the DHCP server on the wireless router.

Depending on what router you have, you don't necessarily have to disable DHCP. You can configure the scope of IP addresses that are assigned. So you could just tell it to not assign 192.168.1.2 (or whatever IP you assign to that WAP.)

It's funny you post this now. My brother got me a Netgear MR814v2 Router/AP for Christmas (what a guy!) Of course, I had to immediately hook it up. Rather than disturb my existing network, I initially hooked it up as an AP doing pretty much the same thing that you talked about here. I eventually did reconfigure everything and let it do its router functions, but I didn't want to do it initially in case I ran into issues (had family staying with us, last thing I need is for my network to go down!)

Went a little OT there, but I thought I'd share my experience.
--
"Back off man, I'm a scientist."

DSLJohnny

join:2001-01-25
Jasper, GA
reply to Shootist
We don't disagree, just another choice presented..
By putting it on a second network, you can't browse to the wired network from the wireless network, and accidentally see the wired network [which you want completely open behind the NAT/router] if you have no security at all on the wireless, which I understand is almost everybody.
You can still do Windows networking across the networks by mapping drives using the IP address of course.
cheers
J

Shootist
Premium
join:2003-02-10
Decatur, GA
kudos:3
reply to Chizep
said by Chizep:
Great thread Shootist See Profile!
said by Shootist:

2. Disable the DHCP server on the wireless router.

Depending on what router you have, you don't necessarily have to disable DHCP. You can configure the scope of IP addresses that are assigned. So you could just tell it to not assign 192.168.1.2 (or whatever IP you assign to that WAP.)

.

Well if you don't disable the DHCP on the second, wireless, router and you connect them together from LAN port to LAN port you will have the 2 DHCP servers trying to assign IP addresses to every PC on the LAN. You must have only 1 DHCP server for each LAN segment.
--
Are You Ready--Stand By BEEP ********

Shootist
Premium
join:2003-02-10
Decatur, GA
kudos:3

1 edit
reply to DSLJohnny
Really as I said in my first reply to your first post this is for the novice networker. To do what you suggest take someone with more experience than the average home PC user. If this person has that type of experience then they would secure there wireless network with the tools at hand.

We do disagree because your suggestion is not any more secure. If you don't use some type of wireless encryption on the wireless side then someone can still break, hack, into, connect to, the wireless side and have access to your whole LAN and your BB connection.
--
Are You Ready--Stand By BEEP ********

GaryP

join:2001-01-07
Cedar Rapids, IA
reply to Shootist
A couple other things that are optional to consider, especially if you use logging on the wireless router acting as a access point:

1. Disable the WAN port entirely, or at least from acting as a DHCP client. How this is done will vary amongst manufactures, but if you don't and you are logging events from this device, you may see failed attempts on the router trying to get an IP address from an ISP on the WAN port (which of course won't work, because you're not using the WAN port). On the Buffalo WBR-G54, I changed the configuration to a hard-coded private address on a different subnet than my internal LAN.

2. If your wireless router can be configured to have the time set using NTP from a server over the Internet and you choose to do this, create a static route telling the NTP client in the router to use your existing wired router address as the route to the Internet for the NTP server. The NTP client in the router will most likely try to use the WAN port as the default gateway for this otherwise. Again, exactly how this is done will vary across manufactures, but hopefully most of them offer this capability.

Once again, both of these steps are optional but help polish off the installation if you wish to enable logging and want to have the time automatically set and accurate as well.

I agree that this is an excellent thread to have started.


Chizep
Premium
join:2002-04-07
Concord, NC
reply to Shootist
said by Shootist:
Well if you don't disable the DHCP on the second, wireless, router and you connect them together from LAN port to LAN port you will have the 2 DHCP servers trying to assign IP addresses to every PC on the LAN. You must have only 1 DHCP server for each LAN segment.

Oops. You're right. You would want to disable DHCP on the wireless router. I read that wrong. I was thinking about DHCP on the existing wired router.
--
"Back off man, I'm a scientist."

Shootist
Premium
join:2003-02-10
Decatur, GA
kudos:3
reply to GaryP
As to your #1: Personally I do all my logging on my main router which if you have the wireless router setup as just a AP and switch everything goes through the main router anyway. No need to log anything on just the wireless side and most home router only log activity through the WAN port not from LAN port to LAN port. Now some might but I don't believe the typical home router, Linksys, D-Link, Netgear and such, do.

As to #2: You would have to use the WAN port on the wireless router to do any time configuring. To my knowledge the time feature will not look on a LAN port for a time server. My post is simply to use the wireless router as a AP with switch. NO router function at all. Using the WAN port on the wireless router starts a second LAN segment and this is not needed for the typical home LAN.

If you really want the the wireless router to preform all these types of functions then just make it the main router.
--
Are You Ready--Stand By BEEP ********


Anav
Sarcastic Llama? Naw, Just Acerbic
Premium
join:2001-07-16
Dartmouth, NS
kudos:5
reply to Shootist
My standard instructions are basically the same.

1. Take a PC wired into the current router. Unplug it from the wired connection and plug into a LAN port on the secondary router. Access the secondary router using your browser via its default LANIP address and default password. Since the PC was attached to the previous router you will have tell the PC to obtain a LANIP from the new device. Use 'winipcfg' win98se or 'ipconfig release/renew' XP on the pC (I have used repair in XP as well)

2. Whilst in the secondary router ( I will call it AP from now on!)

A. change the default password to a minimum combination of 8 letters/numbers/symbols**.

B. Change the essid to a unique name** and make all the necessary wireless configurations necessary**.

3. Then, in the AP, go to the LAN setup page:

A. Turn DHCP serving OFF.

B. Change the LANIP** of the AP from its default so that it lies within the subnet of the primary router but preferably outside the dynamic LANIP range of the primary router.

C. Disable or turn RIP off, if there is that option.

(**WRITE ALL NEW INFO down on a piece of paper.)

4. Now plug the PC back into the wired connection and conduct same process of getting new LANIP. Then suggest also a good time to reboot PC.

5. Plug the AP into the router, LAN PORT TO LAN PORT directly or via switch/patch panel etc.

6. It may be necessary to reboot one or both routers but one should be able to assign LANIPs wirelessly and connect at this point, ensuring wifi card setup properly.
---------------------------------------------------------

Example:

Primary Router
LANIP 192.168.1.1
old Dynamic DHCP Pool 192.168.1.2 - 192.168.1.xx
subnet mask 255.255.255.0

Will need to change Dynamic DHCP pool
new DCHP Pool 192.168.1.33 - 192.168.1.xx (for example)
Subnet mask 255.255.255.0

Secondary Router (our Access Point)
old LANIP 192.168.0.1 -or any other default

Will need to change LANIP to be within subnet of primary.
new LANIP 192.168.1.2
Subnet mask 255.255.255.0
---------------------------------------------------
--
Ain't nuthin but the blues! "Albert Collins". Leave your troubles at the door! "Pepe Peregil". Just Don't Wifi without WPA, "Yul Brenner"

Shootist
Premium
join:2003-02-10
Decatur, GA
kudos:3
Thanks Anav See Profile you laid it out much better.
--
Are You Ready--Stand By BEEP ********


dg2

@fyvlar.swbell.ne
reply to Shootist
re: newer routers having auto-crossover -
Good point. I had hoped that my wired router (about 1.5 yrs. old) would have that, but it didn't. The wireless is a DLink 713, and it apparently doesn't either. If either had, you would have been correct, but I thought I'd throw out the crossover idea for those who don't.

Best bet - try a normal cable first. If no link light appears, try a crossover and see if that helps.

Shootist
Premium
join:2003-02-10
Decatur, GA
kudos:3

1 edit
said by dg2:
re: newer routers having auto-crossover -
Good point. I had hoped that my wired router (about 1.5 yrs. old) would have that, but it didn't. The wireless is a DLink 713, and it apparently doesn't either. If either had, you would have been correct, but I thought I'd throw out the crossover idea for those who don't.

Best bet - try a normal cable first. If no link light appears, try a crossover and see if that helps.

Most of the routers W/switch and just switches I have seen have either auto configuring ports or a uplink port. If they don't have either then you will need a crossover cable. The uplink port is just a crossover port.
--
Are You Ready--Stand By BEEP ********

SoCal99

join:2004-01-22
reply to GaryP
GaryP, I hooked up an Dlink 624 as an AP and a Dlink 724 as my router (long story why). But I am experiencing exactly what you talked about and that is my 624 AP log is filled with 20 pages of failed attempts of the AP trying to get an IP address from the ISP on the WAN port (which of course it won't because I'm not using the WAN port).

I tried to assign a non existent (unused) static IP address and subnet to the AP WAN but after hitting the apply button the Dlink comes back and states "invalid address" and reverts back to Dynamic IP address mode.

So does anyone know how to assign a bogus static IP address to a D-Link DI-624 in AP mode so that it will accept it and stop looking to connect to an ISP thru the WAN port

Lighthouse2
Premium
join:2002-01-23
Missoula, MT
said by SoCal99:
GaryP, I hooked up an Dlink 624 as an AP and a Dlink 724 as my router (long story why). But I am experiencing exactly what you talked about and that is my 624 AP log is filled with 20 pages of failed attempts of the AP trying to get an IP address from the ISP on the WAN port (which of course it won't because I'm not using the WAN port).

I tried to assign a non existent (unused) static IP address and subnet to the AP WAN but after hitting the apply button the Dlink comes back and states "invalid address" and reverts back to Dynamic IP address mode.

So does anyone know how to assign a bogus static IP address to a D-Link DI-624 in AP mode so that it will accept it and stop looking to connect to an ISP thru the WAN port

As you know, the DI-624 has a number of log settings; System Activity, Debug Info, Attacks, Dropped Packets and Notice. We use all of our 624's as AP's and therefore don't use the WAN port. We disabled the Dropped Packets part of the log and don't have the problem you are experiencing. For that matter, you could disable whatever log functionality you find best for your environment.

On the WAN definition, we set up the configuration for static IP and an unused IP address.

SoCal99

join:2004-01-22
Lighthouse, as you know there is an issue with the 624 rebooting so I have System Activities logged (but nothing else) so I can see the reboots. But with this log on I see the "WAN IP address failing message" jamming the logs.

So the difference it that you have assigned a static IP addresses on your 624s and that is why you don't see the entries and it has nothing to do with Dropped Packets logs.

I see your post all over the forum and I can tell you're a smart guy but a lot of your post either state or imply "mine works so you must be doing something wrong"
which is not always the case (like WPA-PSK bug or the rescan after-bootup bug, both of which happen to some but not others).

In this case I agree with your inference that I must be doing something wrong, but the fact the you took the time to write "my works" (paraphrasing) is limited in it helpfulness.

Great it should work, you enter in a used IP address and subnet and hit apply and it should work. In fact, it worked fine when I did it on my 724p+ but when I do the same procedure on the 624 I get an error message...why?...what am I doing wrong? That's the kind of help from a kind, knowledgeable soul that I'm looking for.

Lighthouse2
Premium
join:2002-01-23
Missoula, MT
said by SoCal99:
Lighthouse, as you know there is an issue with the 624 rebooting so I have System Activities logged (but nothing else) so I can see the reboots. But with this log on I see the "WAN IP address failing message" jamming the logs.

So the difference it that you have assigned a static IP addresses on your 624s and that is why you don't see the entries and it has nothing to do with Dropped Packets logs.

I see your post all over the forum and I can tell you're a smart guy but a lot of your post either state or imply "mine works so you must be doing something wrong"
which is not always the case (like WPA-PSK bug or the rescan after-bootup bug, both of which happen to some but not others).

In this case I agree with your inference that I must be doing something wrong, but the fact the you took the time to write "my works" (paraphrasing) is limited in it helpfulness.

Great it should work, you enter in a used IP address and subnet and hit apply and it should work. In fact, it worked fine when I did it on my 724p+ but when I do the same procedure on the 624 I get an error message...why?...what am I doing wrong? That's the kind of help from a kind, knowledgeable soul that I'm looking for.

I really didn't mean to infer that you were doing something wrong and if you got that idea, I didn't articulate myself very well and I apologize.

We have 5 DI-624's running as AP's and I can only pass along what has been working for us. It is painfully aparent that using DI-624's for much of anything is the proverbial crap shoot at Vegas; what you see is what you get and it may not be repeatable or consistant.

All of our DI-624's are revision C1 units with the latest firmware. They are all connected from a LAN port on the 624 to a hub/switch and then to a ZyXel 10W router.

On the 624 configuration screens, we have the following:

WAN: Static IP address pointing to some unused IP address in the same subnet

LAN: A valid IP address and subnet mask (this must be a static IP)

DHCP: DHCP Server is disabled. Static DHCP is disabled

LOG: System Activity = enabled
Debug Information = enabled
Attacks = enabled
Dropped Packets = disabled
Notice = enabled

Aside from the random reboots, this configuration works for us on all five AP's. I can't see any reason it shouldn't work for you but given D-Links history on this device, anything is possible. Log entries are minimal with these setting and we do not show attempts to connect to the WAN port.

I hope this helps.

david_gruenb

join:2004-01-27
Los Angeles, CA
reply to Lighthouse2
I hope this is not off topic. I have been using wireless routers as APs for about a year. The speed on the wireless side is about half of the wired side (325k/s v. 700k/s). Has anyone noticed this? If so, is there a solution to bring the wireless side up to the speed on the wired side? Thanks.


raiste

@bellsouth.net
I am a newie and was wondering if you can set up this configuration using two wireless routers? i.e. using the secondary router as a repeater to extend the range of my wireless network? Or can this only be done with a repeater?


Anav
Sarcastic Llama? Naw, Just Acerbic
Premium
join:2001-07-16
Dartmouth, NS
kudos:5
Depends if the AP portion of the second wireless router was capable of a repeater mode. If the wifi router has a single radio then cut your throughput in half. Better to use a ethernet adaptor bridge into an AP or router for full throughput........
--
Ain't nuthin but the blues! "Albert Collins". Leave your troubles at the door! "Pepe Peregil" De Sevilla. Just Don't Wifi without WPA, "Yul Brenner"


raiste

@bellsouth.net
Thanks for the info. I don't think either of my wireless routers have a repeater mode: SMC 7004VWBR and a Belkin F5D-6231-4.

So all I need to buy is an ethernet adaptor bridge (EAB)? Is this a wireless product?

Would it look like this? Where '----' is a wired connection and '~~~~' is a wireless connection (ignore the periods, spaces would not work to show the computer connected to the first router)?:

Internet----router/AP~~~~EAB----router/AP~~~~computer
..........................~~~~computer

thanks again.


traice

@dsl.sntc01.pacbell.n
I been trying to find out kinda the same thing raiste is, if I set up two wireless routers with one described as above with dhcp off, and the change of the routers ip address. Can I set the second router not connected to the dsl and use that as a access point to connect multiple wired devices in? Using the diagram above

Internet---Router~~~~~~router-----Multiple wired computers.

Is there any downside to this and are there some routers that can't perform this function I was going to purchase a smc 2.4ghz 54mbps (SMC2804WBR) routers today if that would do what described above

SoCal99

join:2004-01-22
reply to Lighthouse2
Lighthouse, I got my system working correctly and I got busy so I didn't look back at this thread until just now. Thanks so much for taking the time to write in detail how your 5 systems are set up, I know that it will help others.

As far as the other stuff, when I wrote my very first post in this forum, I was having problems with WPA and fw version xx, my solution turned out to be fixed in a new fw version released from Dlink that day. When I saw someone else posting the exact same problem I had with WPA, I replied that the new FW fixed the problem for me.

You replied that you had the old version of fw and WPA enabled and it worked just fine and that "I must be doing something wrong."

Being that I had spent over 2 hours on the phone with Dlink and nothing worked but as soon as I installed the new firmware (viola) it worked perfectly, I knew that I wasn't doing anything wrong, but that it was some type of bug.

Anyway, that incident along with the reboot problems, I guess made me a little frustrated and a little defensive, sorry. As I said earlier you're a smart guy and your input to this forum is of great value.

Thanks again for all your help!

Lighthouse2
Premium
join:2002-01-23
Missoula, MT
SoCal99:

No problem. I'm glad you got everything working. I appreciate your comments. Thanks.


raiste

@bellsouth.net
reply to traice
I am not sure. If I had time I might try it out myself. But what little I know about the subject, I don't think it will work.

Hopefully, one of the gurus on here will tell us.