dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1836
share rss forum feed

ReubenL1

join:2004-04-09
Port Hadlock, WA

1 edit

5260 - 5660 Upgrade

Ok, Doc: I'm stuck. I found versions of the 2 files I need (only need, 2, right? to upgrade a 5260 to a 5660?) upgrade.img and 5660.img. the problem: I can't verify the files using a hex-editor (I've tried 2) or 'QuickSFV'.

my Serv-U FTP and Telnet session (man, I am using many things I have never even heard of before this project) gives me the 'file could not be downloaded' error. I'm using a win98 box... w/Serv-U running, I can use a command prompt to 'ping 10.0.0.2' and I get positive result (4 sent/received, 0 lost).

does this prove it's working? dunno. did the wizard, set the 'upgrade.img' folder as home, and telnetted.

quite possibly I have the 'corrupted' 'upgrade.img' (as discussed)
»5260 Modem - flashing green DSL light???
...but I have opened it w/2 different Hex editors (I have no idea what I'm doing here) ... XVI32 and HHD hex editor... but I can't see a way to 'add' the two 0s (zeroes) that everyone is talking about. or even to confirm where, to be honest.

also, just like this person stated in (Re: 5260 Modem - flashing green DSL light???), "I downloaded a hex editor but have no clue on what to do. Where do I find those lines 0xe0 and the check sum at 0xfc. " (from »5260 Modem - flashing green DSL light???)

here's the instructions that I can't make sense of:
»The Unofficial SpeedStream 5260 ---> 5660 FAQ »How can I modify the current 5660 firmware to be directly usable by the 5260?
...I can see NO instances of '0x00000003' or '0xe0'. I get a page full of 2-digit strings.

what a nightmare. can someone point me to a link that has the VALID files, so I can rule out this as a variable? I have way too many of those in this little project.

also, my QuickSFV-to-notepad report gives me this gibberish:
; Generated by QuickSFV v1.71 on 2004-04-10 at 04:07:37
;
; 2472054 03:05.02 2004-04-10 upgrade.img

which looks completely different than what I should expect...!

help, I'm lost in firmware-land

~Reuben

ps- I did find this firmware link, to version 2.3.0(7) if it helps anyone:
»www.alltel.net/downloads/links/5···ate.html


brugar

join:2002-09-16
Las Vegas, NV
kudos:2
Reviews:
·Embarq Now Centu..

> ...I can see NO instances of '0x00000003' or '0xe0'.
> I get page full of 2-digit strings.

Numbers can be represented in several different ways: decimal, binary, octal, hexadecimal, etc. The prefix "0x" is a convention that says the following digits are to be interpreted as a hexadecimal number.

0x00000003 is a 4 byte (two digits/letters per byte)hexadecimal number that will be listed by your hex editor as "00 00 00 03" starting at hexadecimal address e0.


ReubenL1

join:2004-04-09
Port Hadlock, WA

Thanks, brugar. I get the feeling this would help... but none of my Hex editors seem able to display anything but groups of 2-character blocks. it seems un-searchable... both the editors I've tried have 'find' functions, but seem totally useless when it's not displaying them in 'hexadecimal' or whatever it takes for me to be able to see this magical string.

doesn't anyone have a link to a pre-configured, ready-to-install zipped firmware, for 2.3.0(7) 5660 speedstream modems?

oh, a nice surprise: I did get the 'upgrade.img' file to load into the 5260-- so now it's a 5660.

alternatively: does anyone have a (free, of course) hex editor that displays what I need to see, in this situation?

(0x00000003)

thanks much... I'm slowly getting it. I have 5 of these modems, so when I get an upgrade procedure perfected, I'll be able to accomplish something. (still not sure if Qwest will work w/ these modems, as they are unsupported...!)

~Reuben


ReubenL1

join:2004-04-09
Port Hadlock, WA

1 edit

ok. got it figured out, thanks to brugar's clarification. and some experimentation on my own part.

I've decided to save the rest of the planet from the trial-and-error guesswork I went through... so if anyone is still doing this upgrade (not sure if these modems/routers are obsolete yet) I'm posting a link to the two complete and ready-to-use firmware files: upgrade.img and 5660.img (w/some extras):

»www.surfshopcomputers.net/tempor···rade.zip
about 5.7mb

if you ONLY need the firmware images upgrade.img and 5660.img, they're here:

»www.surfshopcomputers.net/tempor···only.zip

around 2.4mb

both these files are the latest (as of today) 5660 firmware: version 2.3.0(7)

enjoy

~R.



2kmaro
Think
Premium,ExMod 1 BC
join:2000-07-11
ColossalCave
kudos:1

Is that software copyrighted and does the site you've linked to have authorization to distribute? If it's been "hacked" are you sure the hacks are only good hacks - or could you be opening up a back door to your own system?
--
Good judgment comes from experience, and experience comes from bad judgment. Barry LePatner



lev
Smells better here without the monkey
Premium,Ex-mod 2002-08
join:2001-05-30
Chicago, IL
kudos:2

I think for safety sake, and to avoid the general grumpiness of Efficient Networks, I'm going to lock this thread down at this point.